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By now, if you're not already using it, you've probably heard a lot about the latest version of Excel. In
the past, Office upgrades involved minimal changes. With this latest edition, though, Microsoft has
shaken everything up. Some people love it; some people hate it. Whatever side of the debate you fall
on, if you have to work in the Office 2007 environment, this handout will highlight some of the changes
and serve as a basic guide for surviving Excel 2007.

The lowdown

Here's a quick list of some of the changes you may find in the new version of Excel. Note: Some of the
differences listed below will be discussed in more detail later in this handout:

e File...Edit...Where did you go? The interface has changed quite a bit; the look and feel is
completely new. Menu items Microsoft has trained us so well to use have been replaced by a
sleeker, more modern “Ribbon” consisting of buttons and tabs.

e File opening can be sluggish compared to Excel 2003. Some users have also reported frequent
crashes and difficulties opening. If this becomes a problem for you, research online forums for
solutions and remember to make backups and save often.

e By default, Excel 2007 saves files with the .xlsx extension. If you or others want to open a file in
an earlier version, you need to use “Save As...” and select “Excel 97-2003 Workbook.” Or, users
can download a converter here:
http://www.microsoft.com/downloads/details.aspx?FamilylD=941b3470-3ae9-4aee-8f43-
c6bb74cd1466&DisplayLang=en

e Gone are the days of 65,536 rows and 256 columns; new Excel can handle more than 1 million
rows and more than 16,000 columns. (Warning: If you open a file that has more than 65,000
records in Excel 2007 and later save it as an earlier version, the old limits go into effect and
you’ll be left with 65,536 rows.)

e The formulas you’ve grown used to haven’t changed a bit. What has changed is the
AutoComplete function. Before, AutoComplete would offer hints in parenthesis to users as they
typed in formulas. That function remains, but in addition, the new AutoComplete offers
definitions and explanations about how each function is supposed to operate.
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e The formula bar is adjustable; you can make it as big or as little as you please.

e Excel 2003 allows you to sort by three different levels; new Excel offers sorts on many levels. It
also sorts by fill and font colors.

e Older spreadsheet file formats, such as Lotus 1-2-3 and Quattro Pro, are no longer supported.

e The PivotTable wizard is gone; in its place is a dialog box that you can launch from the Insert tab.

e Conditional formatting has improved with more options, including the addition of data bars.

e AutoFilter now offers a point-and-click feature allowing you to filter on more than one criterion.
Conditional filtering is also improved.

e Lists in 2003 are now called tables.

Dealing with the Ribbon:

Getting used to navigating Excel 2007 takes time. All of the old tools are there; it’s just a little difficult to
find them. Older versions of Excel consisted of menu items and buttons. The “Ribbon” is what Microsoft
is calling this new interface. It has gotten rid of the menus and added a series of tabs. (Note: Find tools
that look similar to those in 2003 by clicking on the little boxes with arrows in the lower part of the
ribbon. For example, if you click on the little box next to “Number” under the Home tab the familiar
“Format cells” dialog box opens. See Figures 1 and 2.)
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Here’s a quick rundown of what you’ll find under the button and tabs:

Office button: Just about everything that used to be under the File menu in Excel 2003 is now found
under the Office button in the upper left corner (see Figure 3). This is where you’ll create, open, save,
print, email and convert files.
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Home tab: Just about everything that used to be found under the Edit menu in Excel 2003 is now found
under the Home tab. It’s where you’ll go for formatting, changing fonts, copying, pasting, searching,
replacing, etc.

Insert tab: Think of this as the home for anything extra you might want to add to your spreadsheet.
Charts, graphs, hyperlinks, pictures, shapes, tables, etc. This is also where you’ll go to create pivot
tables.

Page Layout tab: The things you used to find under File, Page Setup in 2003 can be found here. This is
where you’ll go to adjust margins, change the page orientation from portrait to landscape, add gridlines,
etc.

Formulas tab: All things formula can be found here. If you forget what function you need to use, this is
where you’ll go to look it up.

Data tab: This one is very important. Any time you need to sort, filter or convert text to columns, you'll
go here. It’s also the place you’ll go when you want to import (called “get external data” in the new
version).



Review tab: Use this when you want to go over your work with tools like spell check, the thesaurus, etc.
You can also use this tab to insert comments.

View tab: Go here when you want to zoom or change the way you see the workbook on your screen.
This is also where you can freeze panes.

Sorting in Excel 2007

One of the most powerful things about a spreadsheet is its ability to sort and organize information
quickly. If you like the ability to sort by more categories and the option of sorting by color, then you're
going to like the updated Excel. As with previous versions, you can use the shift+ctrl+8 shortcut key
combination to highlight a block of data. Then click on the Data tab and select Sort. A window should

open:
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You can add or delete columns you want to sort by clicking on the appropriate buttons. Use the
dropdown box under “Sort On” to select whether you want to sort by a cell’s values or color.

Filtering in Excel 2007

Another benefit of using a spreadsheet is the ability to quickly navigate information to find specifically
what you’re looking for. Filtering is one of the things Excel users have come to love. The 2007 version
allows users to filter on multiple values at one time. The custom filters on numbers have also gotten
easier to use. To turn on filtering in Excel 2007 click on the Data tab and then Filter.

Here's a side-by-side look at how Excel 2003 and Excel 2007 filter a column of professional baseball
teams differently. Figures 5 and 6 below show the dropdown for a filter on a column. Notice that the
2007 version has more options. It allows for a quick sort or a custom text filter option.
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The checkboxes next to values are also a new addition. Excel will filter for values with a check in their
box. To uncheck all of the boxes click once on the box next to “(Select All).” From there you can pick and
choose which values you would like to see.

Let’s say you wanted to select the four Major League Baseball teams that made it the longest in the
2008 playoffs. This would be difficult to do in Excel 2003, but it’s quite simple in Excel 2007. Simply
uncheck all of the boxes and then select the Philadelphia Phillies, Tampa Bay Rays, Boston Red Sox and
Los Angeles Dodgers. Then click on OK.
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To turn filtering off, simply click on the Filter button under the Data tab.
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PivotTables

The process of creating a PivotTable in Excel 2007 is a little bit different. In 2003, you select a block of
data and then start the PivotTable Wizard by going to Data, PivotTable and PivotChart Report... In the
2007 version, you kick off the PivotTable dialog by selecting a block of data and then going to the Insert
tab and selecting PivotTable:
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A window should open with the range of your data selected. You can decide whether you want the
PivotTable to be created in a new worksheet or the one you are working with. Click OK:
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In 2003, the PivotTable Wizard would give you a layout chart that looked something like this:
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In the 2007 version, this widow is gone and everything happens right in your spreadsheet. Use the same

drag-and-drop method as you did before. For example, the image below shows where you would drag

fields to create a PivotTable that lists the total salary for MLB teams:

\ A3

£

<«

A B

C D
Drop Page Fields Here

E

1
2
=R

Drop Column Fields Here

3

i PivotTable Field List r X

Choose fields to add to report:

[Leagee
3 Team

4
5
6
7
8
9

10
1
12
13
14
15
16

aleH splel4 moy doiq

Drop Data ltems Hete]

7
18
i)
20
21
22
23
24
25
26
27
28
29
30
31
32

M 4 » M| Sheatl - mibpa

Ready |
‘4 start

Figure 11

7]

@ My Computer

@ Lexmark X74-X....

/= Gmail - Inbox ...

T Excel - Microso...

Once you've dropped the items into the table it should look like this:

(B Micosoft Excel...

[CIPlayer

alary

Drag fields between areas below:
¥ ReportFilter 4 Column Labels

B Row Labels ¥ Values

[] Defer Layout Update

3 Microsoft Excel...




A B c D E F M M 'ip’wnﬂable Field List v x

1 Drop Page Fields Here |

2 Choose fields to add to report:
3 |Sum of Salary

4 | Team | = [Total [Lezoue

5 [Anaheim Angels | 51830166 [ATeam

6 |Arizona Diamondbacks | 66075999 ClPlayer

7 | Atlanta Braves 73585000 [Fsalary

4 |Baltimore Oricles 78502252

9 Boston Red Sox 59553500

10 |Chicago Cubs 60191500

11 | Chicago White Sox 24580000

12 | Cincinnati Reds 33162761

13 | Cleveland Indians 68061627

14 |Colorado Rockies 55864837

15 | Detroit Tigers 34104666 =

16 |Florida Marlins 18876000

17 |Houston Astros 51629000

18 Kansas City Royals 23706000

19 |Los Angeles Dodgers 79265953 Drag fields between areas below:

20 | Milwaukee Brewers 41395762 7 ReportFilter T column Labels
21 Minnesota Twins 18242500

22 Maontreal Expos 16175500

23 Mew York Mets 62450427

24 Mew York Yankees 55034692

25 |Oakland Athletics 23234333

26 | Philadelphia Phillies 30297500 1 Row Labels T values

27 |Pittshurgh Pirates 22197666 Team - Sumof Salary
28 | San Diego Padres 47828346

29 | San Francisco Giants 44943557

30 | Seattle Mariners 49963503

31 | St. Louis Cardinals 45698333

32 |Tampa Bay Devil Rays 33952500 [ Defer Layout Update
M 4 r K| Sheetl ~ mbpay %2 _ _
Figure 12

You can do a lot of work with the four boxes in the lower right-hand corner of your screen, but for the
most part you won’t need them. The one that you will need is the Values box. Use this box if you want
to change calculations in your PivotTable. For example, the example above summed the salaries for each
team. If you wanted to change that so it averaged the values you would click on the dropdown arrow in
the Values box then select Value Field Settings and click on Average. See figures below:
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You can also sort PivotTables easily in Excel 2007. Simply right click in the column of your PivotTable that
you want to sort and select Sort. If you've created your PivotTable in a new sheet simply use the tabs
along the bottom to navigate back to your original sheet.

Conditional formatting tricks

Excel 2007 has introduced new data visualization features available under conditional formatting. The
data bars tool allows users to see at a glance which values are highest, lowest and how they compare to
other values in your spreadsheet. Below is an example using attendance numbers from baseball games
in 2007. Without even looking at the numbers you can see that the games played at Pittsburgh had the
lowest attendance:
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To do it yourself, all you need to do is highlight the data where you want to insert bars. Click on the
Home tab, then Conditional formatting and data bars:
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Microsoft has put together more information on using data bars. It can be found here:
http://msdn.microsoft.com/en-us/library/bb229709(office.11).aspx.

Getting help
Another menu item casualty from Excel 2003 is the Help dropdown. If you need Excel help look to the
upper right-hand corner of your screen for the small question mark enclosed in a circle:
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One last thing

If you’re still wondering how you’ll survive the transition from 2003 to 2007, Microsoft has put together
this handy interactive guide to help you find any commands you think you’ve lost:
http://office.microsoft.com/en-us/excel/HA101491511033.aspx
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